Mister Rusty Show full post »
Bunkerbarge
I've just received my bottle of Deoxit Gold and am still recovering from the shock.  I knew it was small but Good Grief!!  13 quid for that!!  It had better be good that's all I can say.
Quote 0 0
Mister Rusty
I believe that Red is needed first to clean, then the gold protects.
Hopefully Ahjay can confirm, but it's how l read the instructions. 15672707253076533110030696504883.jpg  15672708826765983028782149193835.jpg  15672709379498041584646756698208.jpg 
My cleaning team, plus all the options previously mentioned.
TTFN
Pete
Bunkerbarge,
I am locked out, hooked up on your last message, this is the only way that l can get into the forum.
Anyone else having issues?
Please check.
Could anyone reading  this, please advise Jazavalley or another admin , thanks
Be careful, in case it's a virus. The message received is:-
The last email that was sent to you was returned as spam by your email provider. Please update your account with a valid email address. Ahjay said  that my details are all in order, correct address and all.
Pete
Quote 1 0
Stimpy
Bunkerbarge wrote:


I wonder if it was a flange diameter issue?  Perhaps with the lower height of the Code 75 the flange edge was catching the chairs?


Could be, plus the design allowing the center axle to float sideways didn't help. For a $400 train that's supposed to work on all tracks I was very peeved!
Quote 0 0
Stimpy
Bunkerbarge wrote:
I've just received my bottle of Deoxit Gold and am still recovering from the shock.  I knew it was small but Good Grief!!  13 quid for that!!  It had better be good that's all I can say.


I've got this stuff. Does it work? Maybe, it's hard to tell since you are looking at so many variables. I would say if it really is helping, it doesn't prevent oxide build up on the rails for very long as I can, with certainty run a cloth along the rail top after a week and pull that black muck up. That's caused by oxidation right? 
.  
Quote 0 0
Mister Rusty
Stimpy wrote:


 That's caused by oxidation right? 
.  

Simon,
Or dirty stock wheels, particularly plastic ones. 😉
Bunkerbarge,
I am locked out, hooked up on your last message, this is the only way that l can get into the forum.
Anyone else having issues?
Please check.
Could anyone reading  this, please advise Jazavalley or another admin , thanks
Be careful, in case it's a virus. The message received is:-
The last email that was sent to you was returned as spam by your email provider. Please update your account with a valid email address. Ahjay said  that my details are all in order, correct address and all.
Pete
Quote 1 0
AHJAY
If thats all you are doing yes, red followed by cold. That instruction assumes electronics-related parts though... where getting to bits to clean physically will not be practical.

I tend to clean mechanically/physically then apply gold....

regards
Quote 1 0
Mister Rusty
Hi Ahjay,
thanks for the modus operandum.
it certainly works, my loco performance through a couple of places has improved considerably.
Bunkerbarge,
I am locked out, hooked up on your last message, this is the only way that l can get into the forum.
Anyone else having issues?
Please check.
Could anyone reading  this, please advise Jazavalley or another admin , thanks
Be careful, in case it's a virus. The message received is:-
The last email that was sent to you was returned as spam by your email provider. Please update your account with a valid email address. Ahjay said  that my details are all in order, correct address and all.
Pete
Quote 1 0