John Ramsay

Hi
does anyone here use tam valley circuit breakers. I have 6 on my layout protecting its district. My problem is two of them have recently failed and burnt out. I have them set at 4 amps and the set up is 
Gaugemaster prodigy advance 2 controller >>>>>alpha box>>>>>DCC Concepts bus bar>>>>>>> Tam Valley CB>>>>>>District Track

i also have a dcc Concepts’s power box to feed the alpha box. 

I hope someone can help. 

john

Quote 0 0
AHJAY
There is nothing in your system that would contribute to the failures, so I guess its just component failure in the Tam Valley product. You use the term "Burned out" - is it an obvious failure (visible component appearance change) or did they just stop working?

regards, Ahjay
Quote 0 0
John Ramsay
Hi Ahjay
they did burn out. The board had some black marks on it and the fixing rubbers on the back had melted slightly down the back of the board. This suggests to me that the component overheated. Someone suggested I may have had a long short where possibly a loco stalled on a point set against it and was speed creeping which caused a long short which in turn overheated the component. 
Quote 0 0
AHJAY
Could be, but if that is the case the design should really current limit to prevent this.

Many DCC products work well on the bench but are not so good in real terms as its perhaps something not thought about or tested for - design for modellers has many surprises...

I'd send them a polite email, explain the problem and asking for help. It will be cheaper to for them just replace probably - and they may do it no charge. worth a try

regards, Ahjay
Quote 0 0
John Ramsay
Thanks Ahjay. I have sent them back to where I purchased them, Coastal DCC, who have replaced them free of charge. He will send them back to manufacturer and we await their findings. 
Quote 1 0
AHJAY
Good to hear - Coastal are good people and always look after their customers well

Ahjay
Quote 1 0